vins
Hello. Recently I assembled my first Tevo Tarantula. Used Ed's youtube guide (https://youtu.be/kjc8OBsKi0U?list=PL7OGtDmFA6R6nBhSznM8lyO57RcmNu6Vk) for reference and assembly was fairly ok.

First I stumbled with some problems from Z-axis (it didn't work, even board was new), but that I solved with interchanging pins from Z to E1.

Y-axis have some issues that I have no clue how to solve - when I turn printer on and try to home Y-axis, then stepper motor gives some strange BRRRRR sound, but nothing happens (no stepper movement - marked with marker to see if there are some movement/slipping)... board thinks it actually moving, thought bed ain't moving... after few moments (when homing is at the end) bed moves ok for a bit. After this point there is no problem homing bed (it goes in correct direction and stop at endstop as supposed to) or moving bed whatever direction - everything works. This problem repeats fairly often and 100% percent when turning on printer. There is no similar problems with X or Z axis.

My belts is tight strongly and its put on correctly (as far as I can tell - according to
)

I am using tarantula-marlin.community-v.0.1d firmware and for Y-axis I made change in variable INVERT_Y_DIR so it goes correct way.

Maybe someone have any clue what should I look for?

I will try to change steppers around to see if that will help.
Quote 0 0
MattCP
Hiya,
Did you solve this issue?
I have just this moment finished building the kit and I have a similar issue...plus the Y end sop does not respond.

Quote 0 0
vins
Yes, I solved my problem by purchasing new mother board, as one I got was broken (at least when I put new one, everything worked perfectly), btw two stepper controllers where broken, one with this skipping effect as mentioned above, other not working at all. I bought this one http://www.banggood.com/MKS-BASE-V1_4-3D-Printer-Control-Motherboard-Compatible-Ramps1_4-p-951135.html and it works like a charms, no problem at all with Marlin 1.1 Rc7 (if not mistaken).

Btw, I also asked from printer supplier to solve this problem, by mentioning, that I think stepper controllers are broken, but only solution I was given, was go to facebook... :/ 
Quote 0 0
Hey_Allen
I was having the "brrrt" sounds on my Black Widow, with an E3D extruder when I tried to feed filament, but had seen discussion a while back about wiring stepper motors and getting wires crossed up.

After powering the printer off, I switched the two center wires on the motor end plug, just to test it, and the stepper started working correctly.

Now, this may not fix it for others, but this is a simple thing to check if your steppers are buzzing/ratcheting instead of rotating.

You can also switch the direction that the stepper runs by switching one of the outside pairs of wires.  Switching both negates the change, and the motor will be rotating the same direction as when you started...  (That said, I usually just switch the motion direction in the firmware, instead of flipping the wires.)
Quote 0 0
03dom
Just set up my printer and I am having the same issue with the Z motor stuttering making an awful sound and not turning properly / weakly, even when not connected to any mechanical load. It seems to have to do with the corresponding controller or plug on the board because if I plug in another motor that worked fine, e.g. y, it behaves the same. Hence it must be the controller.
Will try to switch to E1 then check the reference voltage as seen in some video and finally asking for a replacement of the board, if these things don't solve it.
Quote 0 0
03dom
Update (help appreciated):

Configuration:

TEVO Tarantula
Board: MKS Base V1.4
Loading original Repetier Software from webpage and flash over Arduino IDE 1.6.8

Reproducible behavior:

Homing only X: works fine. Two pumps into the end top, then silent.
Homing only Y: works fine. Two pumps into the end top, then silent.
Homing only Z: does not work. Jittery movement of motor, noisy.

Homing all: X works fine. Y bumps once, then starts to jitter like Z. Gets stuck in this loop, i.e. does not finish Y and move on to Z.

Switching cables between Y and Z or the Extruder to test these motors with manual motion: motor and cables are fine.

Measured all potentiometers relative to VCC-:
X: 0.77 V
Y: 0.72 V
Z: 0.00 V (turning potentiometer does not lead to change)
E0: 0.73 V
E1: 0.73 V
Quote 0 0
hsaturn
Reading fast this issue My first reaction was

Maybe you should adjust the current.

My extruder was not moving until I adjust the potentiometer on the board for E0.

Problem has gone , (and no need to buy another board).
Quote 0 0
antivenom64
Hi, I have this exact problem but it is with my y axis and it only moves in one direction. When I go to move the y axis I can only move it in one direction and when I turn the knob back it doesn't do anything HELP!!
Quote 0 0

Add a Website Forum to your website.